gtkdoc problem

Erwin Rol mailinglists at
Tue Jul 1 14:21:01 UTC 2008

Hello all,

I have a problem with gtkdoc on Fedora 9. It doesn't want to resolve
external references like;

<?xml version="1.0"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" 

"" [

After trying to see if it was a network problem i noticed that there was
never any network traffic for that URL. With strace i noticed it tried
to stat() the URL and that of course returns an error. 

When i than looked into gtkdoc-mkhtml i found a --nonet option was used
for xsltproc. When i removed that option everything worked fine. (I also
tried this with the glib sources, not just my own stuff).

The following patch does the trick;

--- /usr/bin/gtkdoc-mkhtml.orig	2008-07-01 15:45:25.000000000 +0200
+++ /usr/bin/gtkdoc-mkhtml	2008-07-01 15:45:34.000000000 +0200
@@ -42,7 +42,7 @@
 if $is_xml; then
-  /usr/bin/xsltproc --nonet --xinclude \
+  /usr/bin/xsltproc --xinclude \
       --stringparam gtkdoc.bookname $module \
       --stringparam gtkdoc.version "1.9" \
       $gtkdocdir/gtk-doc.xsl $document || exit $?

But somehow this can't be the right solution :-) anybody know what the
real fix for the problem is ?



More information about the fedora-list mailing list