gtkdoc problem

Erwin Rol mailinglists at
Tue Jul 1 21:14:09 UTC 2008

On Tue, 2008-07-01 at 15:40 -0400, Todd Zullinger wrote:
> Erwin Rol wrote:
> > docbook-dtds-1.0-35.fc9.noarch is installed on my system. But I
> > don't think that is the root of the problem. The SGML files have a
> > reference to a http URL, not a local file. And gtkdoc-mkhtml seems
> > to decide that it will not load anything from the net.
> I'm still of the opinion that this is caused by missing packages, as
> it has been in the cases I've run across.  What is it that you're
> building?  Can you post the output (or a link to it if it's really
> large)?

I ran into problems with some stuff i was working on, but to be sure it
isn't my own poor automake knowledge I just downloaded the official glib
tar.gz (not rpm) sources and used those to test (with the same result). 

> > Well i "fixed" gtkdoc-mkhtml by removing the --nonet, so for now it is
> > OK, but I am just wondering if it is just me being stupid, or if the
> > tool is broken.
> When building official fedora packages, mock doesn't have a network
> connection on the buildsystem, so removing the --nonet wouldn't work
> there and we need to find a better solution. :)

OK that than explains why the --nonet is there. But some ppl might want
to be able to load things from the net. Would it be an idea to have
something like a --enable-net option for gtkdoc-mkhtml ? That way ppl
can just add that option in their and there is no change to
the Fedora buildsystem. 

> It might help to add the --verbose flag to the xsltproc call in
> gtkdoc-mkhtml.

- Erwin

More information about the fedora-list mailing list