F9: USB memory stick won't mount [SOLVED???]

Brian Mury brianmury at alumni.uvic.ca
Tue Jul 1 23:41:04 UTC 2008

On Tue, 2008-07-01 at 17:58 -0500, Mikkel L. Ellertson wrote:
> It looks from the messages that it is being properly detected, but 
> HAL is not mounting it. While it does not explain the problem, you 

lsusb shows it as "Feiya Technology Corp. Memory Bar". Google found
this, and some other similar pages:


Unfortunately that fix didn't work for me - the entry in
10-usb-music-players.fdi does not exist.

> may be able to get it to mount if you give it a label. For the FAT 
> file system used on most memory sticks, it is easy to do in Windows, 
> but it is a bit complicated to do in Linux.

I tried it in Windows, it appears to already have a label ("CORSAIR").

If I mount it from the shell, as root, it shows up as "8.1 GB Media", no
name... and the "USB Drive" is still there and unmountable (that is,
there are two separate GNOME icons after mounting).

It is formatted as FAT32, BTW, so that should be ok.


Ok... This is strange... While writing this email, I was moving the
drive back and forth between a Windows and a Fedora box. I mounted it as
root, wrote a short text file to it, moved it to Windows, edited the
file, moved it back to Fedora and it worked... Tried unplugging/plugging
a few tries and it seems fine. Weird.

More information about the fedora-list mailing list