gtkdoc problem

Tim ignored_mailbox at
Wed Jul 2 03:55:55 UTC 2008

On Tue, 2008-07-01 at 16:21 +0200, Erwin Rol wrote:
> I have a problem with gtkdoc on Fedora 9. It doesn't want to resolve
> external references like;
> <?xml version="1.0"?>
> <!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" 
> "" [
> ]>
> After trying to see if it was a network problem i noticed that there was
> never any network traffic for that URL. With strace i noticed it tried
> to stat() the URL and that of course returns an error. 
> When i than looked into gtkdoc-mkhtml i found a --nonet option was used
> for xsltproc. When i removed that option everything worked fine. (I also
> tried this with the glib sources, not just my own stuff).

I wonder if it's expected to work like the ideal (*) web browser:  They
don't fetch the DTDs, they have internal copies of the standard known
DTDs, and only fetch the ones that they need to.

In reality, web browsers pay scant regard to specs, but the behaviour I
outlined is a textbook DTD handling methodology.  After all, you
wouldn't want to go fetching the DTD each time you read standard HTML,
it's rather wasteful, seeing as the DTDs don't change.

[tim at localhost ~]$ uname -r

Don't send private replies to my address, the mailbox is ignored.  I
read messages from the public lists.

More information about the fedora-list mailing list