F9: USB memory stick won't mount [SOLVED???]

NiftyFedora Mitch niftyfedora at niftyegg.com
Wed Jul 2 23:48:44 UTC 2008

On Tue, Jul 1, 2008 at 4:41 PM, Brian Mury <brianmury at alumni.uvic.ca> wrote:
> On Tue, 2008-07-01 at 17:58 -0500, Mikkel L. Ellertson wrote:
> > It looks from the messages that it is being properly detected, but
> > HAL is not mounting it. While it does not explain the problem, you
> ===============================
> Ok... This is strange... While writing this email, I was moving the
> drive back and forth between a Windows and a Fedora box. I mounted it as
> root, wrote a short text file to it, moved it to Windows, edited the
> file, moved it back to Fedora and it worked... Tried unplugging/plugging
> a few tries and it seems fine. Weird.

I have seen this as well.

What I suspect is that the interactions as root establish  the correct
mount flags
for the device.   Then at a future time  a user can mount it because the config
established by root is the configuration needed for the daemon to mount
the device later.

There has been a lot of attention to company data theft via USB devices.
It may be that you are seeing interactions with a policy framework intended to
address this.

Do look for and at /media/.hal-mtab

Since it is a "one time only problem" it will take some care to file a
bug with a test case, instructions to reproduce etc.

T o m M i t c h e l l

More information about the fedora-list mailing list