Fedora 9 X dual monitor problem

David Kramer david at thekramers.net
Fri Jul 4 23:56:35 UTC 2008

I recently "upgraded" my laptop from Fedora 8 to Fedora 9. As always, I 
backed up the old system and started from reformatted drives. I never 
upgrade my OS in place. This is on my Dell Latitude D820 with a 15.4 
inch 1680x1050 screen, using the proprietary Nvidia driver. I've had 
quite a few problems with F9. I don't know how much of my pain is coming 
from KDE4 being fresh out of the oven, and how much of it is F9 itself.

When I was running F8, I was able to sucessfully hook up the external 
video port to my Sony Bravia TV's PC port. It does 1380x768. This is 
essential functionality for me, so I can watch MythTV on the TV while 
using my internal screen for email/web/etc. I used separate Xs, not 
TwinView or Xinerama (I experimented with those, but windows would 
launch on the TV when it wasn't hooked up, so I couldn't get to them). 
And all was right in the world

After I loaded F9, I'm not able to get the TV to display anything. I see 
a crosshatch pattern over the screen, and if I move the mouse to that 
screen, I see the cursor, but I can't right click or left click. I even 
tried the exact xorg.conf from F8, and that didn't work either. Instead 
of the crosshatch pattern, the TV was just black.

I have a complete writeup, with links to the config and log files at:

Someone suggested that X wasn't starting on that screen (:1), and to try 
to start it separately, but that didn't work.
[david at lexa ~]$ export DISPLAY=:1
[david at lexa ~]$ echo $DISPLAY
[david at lexa ~]$ kwin
kwin: FATAL ERROR while trying to open display :1
[david at lexa ~]$ metacity
Window manager error: Unable to open X display :1
[david at lexa ~]$

     * Config file two screens, worked in F8, but not F9
     * Log file (from F9), two screens, worked in F8 but not in F9
     * Log file, single screen, works
     * Config file, single screen, works
     * Log file, two screens, broken
     * Config file, two screens, broken

Some other related problems I'm having:

     * nvidia-settings puts an entry in xorg.conf for RgbPath, and X 
fails to start, claiming it's invalid. I have to remove that line every 
time I rerun nvidia-settings.
     * It says it can't load the module type1, but I can't see any 
packages (using yum or yumex) having to do with type1 fonts that isn't 
     * It looks like glx is loading when you look at some parts of the 
log files, and that it isn't in others. How can I tell for sure, and how 
can I fix it if it isn't loading?
     * The fonts applications and KDE use seem very inconsistent. I have 
Firefox and Thunderbird to use font sized 10 and 12 for most things, but 
sometimes they will show text using a font that looks like it's at least 
20, and sometimes emails appear in a font too small to easily read, and 
in light grey. I have it set to view in plain text and quoted lines in 
black in the same font. I know that sounds like a Thunderbird problem, 
but since I'm having font troubles in general, I'm not sure. Also not 
sure if it's related to the type1 module problem above.


More information about the fedora-list mailing list