Networkmanager seems to ignore WEP code

Kevin J. Cummings cummings at
Sun Jul 6 17:42:59 UTC 2008

Luis Orlindo Tedeschi wrote:
> Would the WPA problem affect the WEP?

(For those who have forgotten, my laptop is running F9 x86_64. 
Up-to-date through yum daily.  It has ipw3945 hardware, and I'm using 
the iwl3945 wifi drivers.)

I read through *all* the duplicate bugs and the comments in 453390, and 
many people claimed that while WPA/WPA2 was whacked, WEP still worked 
for them.  The general claim is that it was a bug in wpa_supplicant.  If 
so, it should have *no* effect on WEP, which is implemented elsewhere 
(isn't it?).

I find this really strange, because, I booted the new .9-76 kernel 
yesterday, and it connected to my AP right away.  My AP is a wrt54g, 
V3.0, still running its original firmware.  And I'm using WPA-AES 
encryption, (though I've been thinking of moving to WPA-TKIP and maybe 
changing my channel B^).  This appears to be the opposite behaviour from 
everyone who did a me2 on that bug report!  What works for them fails 
for me, and what fails for them works for me.  Really strange.

2-3 weeks ago, I took a long holiday away from home.  Brought the laptop 
with me because the inn claimed to have free WiFi.  In fact, they had a 
small Airport AP running 40-bit WEP.  (while I was still running the 
.6-55 kernel) NetworkManager found the AP just fine, but wouldn't 
connect.  It just kept re-prompting me for the passphrase.  Well, 
actually, it had encoded the passphrase and prompted me to reenter the 
encrypted 40/128 bit encoding, which was a hex string.  Nothing I tried 
would connect.  So, when I retired to my room for the night, to my 
surprise, the laptop found the open wireless from the house across the 
street!  Bing, bada boom, it connected (I didn't even *ask* it to)!  (no 
encryption, not WEP, not WPA, nothing).

When I got back home, I was able to re-connect to my house.  WPA-AES. 
It connected first try.  Really strange!

Now, after seeing all of the complaints about .9-76, I waited until I 
tried to view a DVD, and my system panicked.  When I re-booted, it was 
the latest kernel, and I expected the WiFi to fail.  "Surprise, 
surprise, surprise Sergeant Carter!"  It connected first time.  I even 
suspended my lappie overnight, and when I re-booted, it connected again!

So, maybe I don't know what the bug is, but maybe its related to 
WPA/WPA2, but not WPA-AES?

And I have no clue as what's wrong with WEP, as a lot of the people 
commenting on the bug claims they have no problems using WEP!

So, here I am, not a general user of WEP, having problems getting it to 
work at all.  Its not one of my "standard" setups.  I only expect to use 
it rarely.  But, I expect it to work when I do, so when it doesn't, it 
makes it really hard to fix (How do you fix your internet connection 
when you can't get it to work????)  How am I supposed to then google for 
the answers?!

Kevin J. Cummings
kjchome at
cummings at
cummings at
Registered Linux User #1232 (

More information about the fedora-list mailing list