Hp Photosmart - scanner not detected.

Patrick O'Callaghan pocallaghan at gmail.com
Mon Jul 7 05:22:43 UTC 2008

On Sun, 2008-07-06 at 21:47 -0700, Mick M. wrote:
> Hi;
>  I have an HP Photosmart C5180 all in one printer/scanner.
> It worked fine in F8 both as a printer and scanner.
> Now here I am a bit fuzzy.
> I *Think* it worked ok in F9, I don't scan much.
> Now it prints but is not detected as a scanner.
> This is a USB device.
> I uncommented the two lines in /etc/sane.d/hp.conf
> # Uncomment the following if your scanner is connected by USB,
> # but you are not using libusb
>  /dev/usb/scanner0
>   option connect-device
> There in no /dev/scanner
> I can't figure out how to usw /sbin/MAKEDEV to make one.
> This is a fully updated F9 KDE box.
> [root at localhost ~]# uname -r
> [root at localhost ~]# rpm -qa *sane*
> sane-backends-devel-1.0.19-10.fc9.i386
> sane-frontends-1.0.14-4.fc9.i386
> sane-backends-libs-1.0.19-10.fc9.i386
> sane-backends-1.0.19-10.fc9.i386
> xsane-gimp-0.995-3.fc9.i386
> sane-backends-libs-gphoto2-1.0.19-10.fc9.i386
> xsane-0.995-3.fc9.i386

# yum install hplip
# hp-setup

I have the exact same printer/scanner and it works perfectly on F9 using
the hplip tools. The only difference is I have it connected to my local
LAN via its builtin Ethernet port, and for some reason on setup I had to
supply its IP address as it wasn't detected automatically, but from then
on it's been trouble-free.

For what it's worth:

# rpm -qa \*sane\*


More information about the fedora-list mailing list