Can't import pictures from Camera

Patrick O'Callaghan pocallaghan at
Mon Jul 7 12:46:19 UTC 2008

On Mon, 2008-07-07 at 13:30 +0100, Colin Paul Adams wrote:
> >>>>> "Patrick" == Patrick O'Callaghan <pocallaghan at> writes:
>     Patrick> On Mon, 2008-07-07 at 12:50 +0100, Colin Paul Adams wrote:
>     >> This was working until yesterday.
>     >> 
>     >> Now I if I try get:
>     >> 
>     >> An error occurred in the io-library ('Could not lock the
>     >> device'). Camera is already in use.
>     >> 
>     >> The latter is certainly not true. And it will work ok on my
>     >> MacBook Air. But obviously I prefer to use Linux.
>     >> 
>     >> Any clues? The camera is a Nikon D300.
>     Patrick> You don't say what application you are using to access
>     Patrick> the camera.
> It doesn't make any difference.
> I've tried both gThumbImageViewer anf Fspot.

Cameras can be accessed in two different ways, either as a hard disk
image, or using a built-in protocol (manufacturer-defined). Do both of
these fail? Have you tried digikam? Is the camera connected via USB or
Firewire? If USB, have you recently updated the libusb package (say
within the last week or so)?


More information about the fedora-list mailing list