Can't import pictures from Camera

Patrick O'Callaghan pocallaghan at
Mon Jul 7 13:51:50 UTC 2008

On Mon, 2008-07-07 at 13:53 +0100, Colin Paul Adams wrote:
> >>>>> "Patrick" == Patrick O'Callaghan <pocallaghan at> writes:
>     Patrick> Cameras can be accessed in two different ways, either as
>     Patrick> a hard disk image, or using a built-in protocol
>     Patrick> (manufacturer-defined). Do both of these fail? Have you
>     Patrick> tried digikam? Is the camera connected via USB or
>     Patrick> Firewire? If USB, have you recently updated the libusb
>     Patrick> package (say within the last week or so)?
> I have only tried using USB-PTP.
> I dare say libusb may well have been updated during the last week. It
> is currently at libusb-0.1.12-15.fc9.x86_64 .

AFAIK that's the latest one. The reason I asked is that there was a
problem for a few days that affected CD burning and appeared also to
affect other block devices, however I'm guessing that wouldn't touch
PTP. In any case the latest libusb fixes it.

The most likely explanation is that there is a lock file lying around
which shouldn't be there. Rebooting might get rid of it, or you could
poke around in /tmp.


More information about the fedora-list mailing list