F9: Func and Certmaster

Dan Thurman dant at cdkkt.com
Thu Jul 10 00:35:28 UTC 2008

Dan Thurman wrote:
> I found out the hard way why I was getting a grub-startup
> with a traceback error I luckily captured with a ^s.
> I found out that funcd failed to start because it could not locate
> a certmaster server running. So noticed that funcd was not running
> and manually tried to start it. The error that appeared shows exactly
> the same traceback in the grub startup as follows:
> # service funcd start
> Starting func daemon: /var/run/funcd.pid
> Traceback (most recent call last):
>  File "/usr/bin/funcd", line 10, in <module>
>    server.main(sys.argv)
>  File "/usr/lib/python2.5/site-packages/func/minion/server.py", line 
> 258, in main
>    requester.request_cert()
>  File "/usr/lib/python2.5/site-packages/certmaster/requester.py", line 
> 22, in request_cert
>    utils.create_minion_keys()
>  File "/usr/lib/python2.5/site-packages/certmaster/utils.py", line 
> 174, in create_minion_keys
>    raise codes.CMException, "Could not locate certmaster at %s" % 
> master_uri
> certmaster.codes.CMException: Could not locate certmaster at 
> http://certmaster:51235/
> Now, I suppose that I can simply disable the func from services but 
> then again, it may
> not solve my problem related to a previous posting regarding the 
> failure to start my
> services gui: system-config-services as it fails with no error 
> messages, no system log
> data, but then again, this may not even be related.  So I decided to 
> post this tidbit of
> information so that others may not have problems, if any.
> I have not configured anything for certmaster - not knowing anything 
> about it nor about
> func either.
> Can someone shed some advice here?
Ok, I disabled funcd in the service and I know that this has nothing
to do with system-config-services.  It still hangs.  Different issue to
solve.  But anyway, with funcd disabled, there is no tracebacks so
I solved that issue for now.

More information about the fedora-list mailing list