xorg.conf font setting kills gnome

Jack Howarth howarth at bromo.msbb.uc.edu
Thu Jul 10 17:34:54 UTC 2008

    I ran into an issue with the xorg.conf settings
under Fedora 9 this week which was pretty painful to
debug. We found one Fedora 9 machine which had stopped
allowing users to log into the gnome desktop. The desktop
background would appear but the login would freeze. Oddly
the KDE logins worked fine. After reinstalling all of
the gnome related packages, I discovered that under the
KDE desktop that gnome applications would fail to launch
with the error...

The program 'gedit' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadName (named color or font does not exist)'.
  (Details: serial 352 error_code 15 request_code 45 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

It appears the the xorg.conf on this machine contained the lines...

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

        FontPath     "unix/:7100"

and removing this solved the issue. Shouldn't gnome be more tolerant to
this issue like KDE? I might not have figured out this problem if KDE
wasn't available on that machine to allow me to debug the problem (since
no error messages related to these font failures were logged anywhere
in /var/log).

More information about the fedora-list mailing list