Fedora 9 Openchrome drv HP w2207h Monitor -- new drivers?

Beartooth Beartooth at swva.net
Thu Jul 10 21:57:57 UTC 2008

On Sun, 06 Jul 2008 15:56:37 +0000, Beartooth wrote:

> On Fri, 04 Jul 2008 02:20:14 +0200, Björn Persson wrote:
> 	[...]
>> I don't understand it either but similar things happen to me. If I boot
>> into runlevel 5 I only get a black screen. If I boot into runlevel 3,
>> log in as root and run "init 5 ; exit", then X starts just fine. I've
>> described the problem here:
>> https://bugzilla.redhat.com/show_bug.cgi?id=448340
> 	I'll take a look at that shortly, thanks.
>         Meanwhile, I did manage to get #1 as well as #2 machine to run
> F9;  but unless/until I hear better from Frank Murphy, I have to boot
> both in init3, log in as root, and play with the X configuration first
> by editing /etc/X11/xorg.conf and then by running system-config-display.
> That gives me a weird error message, something to the effect that the
> connection to the Xserver is temporarily unavailable. But if I then log
> root out and my userid in, I can command startx, and it takes a while
> but works.
> 	Next time I have to shut one of them down, or sooner if I get to
> it, I'll try your way instead; it certainly sounds shorter and easier.
> And, come to think of it, last time I did mine, I didn't change anything
> with either my editor or my config command; just ran them, logged root
> out and userid in.

	One relevant and one almost surely relevant discovery.

	My #1 hardware (with the VIA card) didn't like the xorg.conf file 
that Frank Murphy sent -- not quite; but almost. I made three copies, 
with changes in each; first with "vesa" replacing "openchrome" as the 
driver; second, with the resolution choked all the way back from 
1680x1050, which the monitor demands, to 1280x1024, which I know both 
machines #1 and #2 can handle; third with both those changes.

	With the first, the vesa version, I didn't just boot, but took 
the Persson Precaution : edited grub to boot to init 3, logged in as 
root, and simply commanded "init 5."

	That worked so well I haven't tried anything else yet, not even 
booting without the Persson Precaution. I have full use of the whole 
1680x1050 resolution, and have had neither any sort of display 
breakdowns, nor any other trouble. I look forward to getting #2 (with the 
nvidia card) to do as well some day.

	Since then, yum update on at least one machine (I wish I could 
remember which! But I may have spotted the like on only one but gotten it 
on both...) -- on one machine, I say, yum update has brought at least a 
dozen X11 items, about half containing the substring "-drv-"; I *think* 
those must be drivers, right? 

	Has anybody else tried any of them with the HP w2207h yet? Would 
it be a good idea just to run system-config-display again? 

	Perhaps try the list of HP flat panel monitors, which didn't 
include this one last time I looked? Or run system-config-display only 
after editing a particular one of them into xorg.conf?

Beartooth Staffwright, PhD, Neo-Redneck Linux Convert
Remember I know precious little of what I am talking about.

More information about the fedora-list mailing list