How to change LBA48 addressing capability

g geleem at
Fri Jul 11 06:06:52 UTC 2008

Dan Hensley wrote:
> Well, strange things have happened.  During my transition from FC6 to
> F9, I had disconnected a 3rd drive in my system, an EIDE drive.  While
> it was disconnected I was experiencing the disk problems with my 2nd
> drive.  So I plugged the 3rd drive back in, and now the 2nd drive is
> behaving perfectly.  So it seems like this problem is due to some kind
> of strangeness in the BIOS.  I have an Asus board.

welcome to world of electronics. i have been in electronics for 55 years
and electronics still fascinates me when such as this happens.

/dev/hda and /dev/hdb indicate they are on primary controller with hda
as master and hdb as slave, and jumpered such.

on secondary controller, 3rd drive 'should' be master and map as
/dev/hdc with a cd/dvd jumper as slave, /dev/hdd, and seen as cdrom0.

without a master hard drive, cd/dvd should be jumpered as master. yet i
have seen cd/dvd drives jumpered as slave and still work as master in
a single drive on controller. even seen as such in bios.

now, with drives being set up as scsi devices, it may not hold true and
may be what was causing your problem.

i say this because after changing from lilo to grub boot loader to get
fedora 8 to work, i had an sda drive crash. in replacing, i had to do a
bunch of drive swaping and during such, i ended up moving installs
between 4 drives to rebuild things to capacity of drives.

after getting things back down to 3 drives + dvd drive, i rebooted,
reset bios for dvd and tried to boot my main linux installation on
drive2. during init, it hung up during drive check on 3rd drive and
not get passed it.

tired and a little peeved, i decided to drop back from 3 installs and
3 drives to 2 on 2, + 1 cd and 1 dvd drive.

after pulling cover and starting to pull 3rd drive connector, i noticed
that connector on 3rd drive was not fully seated so i pulled it off and
reseated it. reboot and all was well.

i can only attribute this to a possible lost of a signal needed during
drive check as it was passing bios check.

granted, 3 hard drives + 1 dvd drive were listed in bios and fstab and
drive checks were looking for it and caught problem, but bios missed
for some reason.

long story to short, *always*, when swapping hard drives and cd/dvd
drives, check _all_ jumpers and cabling before closing case and powering
system back up.

it was a habit that i got out of, but never again.

on a curious note, what does 'hdparm -I' now show?

> Oh well.  At least it works now.

that is the main thing and it was a simple fix. i would bet i know
what you will also do before you close a case. ;o)





in a free world without fences, who needs gates.

More information about the fedora-list mailing list