KDE hosed - no display

Anne Wilson cannewilson at googlemail.com
Fri Jul 11 09:33:46 UTC 2008

On Friday 11 July 2008 09:42, Anne Wilson wrote:
> This morning my F9 box gets to the login screen, then I get a white box on
> a black background.  The white box disappears and I'm left with a black
> screen. It seems that things carry on in the background, as, after a while,
> I get the chimes that signal that the system is ready to go.
> I've checked that it isn't the kernel that's the problem - it happens on
> both kernels.  The session menu at login doesn't show any other dm, so I
> thought I must have forgotten to install an extra one.  I went into
> failsafe mode and first tried for updates, to be told that there are none. 
> I then tried to install gnome-desktop, figuring that it would pick up the
> necessaries from there.  It says that gnome-desktop is already installed.
> At this point I'm at a loss to know what's next.  Advice?
/var/log/messages tells me that

pulseaudio failed
X server for display :0 terminated unexpectedly (presumably the important one)

restorecond: Will not restore a file with more than one hard link 
(/etc/resolv.conf) Invalid argument

/etc/resolv.conf contains the IP addresses of my ISP's two nameservers.

There's no clue as to why the X server terminated.  

System-config-display appears to be using correct settings.


More information about the fedora-list mailing list