smbclient -N --no-pass broken

Michael Schwendt mschwendt at
Thu Jul 17 09:42:43 UTC 2008

On Wed, 16 Jul 2008 19:01:59 -0700, Skunk Worx wrote:

> Example :
> $ smbclient -A /tmp/foo -N // -D / -c ls
> Where :
> /tmp/foo contains :
> username=uname
> password=pass
> Under F7 this worked fine. The -N (or --no-pass) option helps deal with 
> broken credentials files (/tmp/foo) so no prompt is requested or shown. 
> For example in scripts, which should not hang.
> Under F9 this fails with :
> Anonymous login successful
> Domain=[FOO] OS=[Windows 5.0] Server=[Windows 2000 Lan Manager]
> tree connect failed : NT_STATUS_ACCESS_DENIED
> I don't see anything in bugzilla about this. Should I bz or ask 
> elsewhere about this?

Options -A and -N are unrelated. Both skip the password prompt to
make smbclient non-interactive. -A because it can read the credentials
from a file. -N because it is used when no password is needed (login
as guest/nobody). Either one worked for you, but access to the share
was denied. What do you think is the bug?

More information about the fedora-list mailing list