F9: Using dd to clone a drive...

Dan Thurman dant at cdkkt.com
Fri Jul 18 23:48:48 UTC 2008

I used dd off the Gnome Live CD, so that neither
drives were mounted nor active. Next I proceeded
to use dd as follows:

dd if=/dev/sda of=/dev/sdb

It took approx. 6 hours to copy over 450GB of data.

I was successful at getting getting Grub to come up, was
able to select XP and Vista partitions and these booted up
just fine.  Great!  I checked everything and these worked
fine as far as I can tell.  But when I tried to boot Fedora 9,
there was a whole raft of errors spewed out, from "Stale NFS"
errors, missing/corrupted/perm problems with  /var/run,
/var/bin/id, I was not able to tell what the problem and the
list is endless.  In short, I was not able to boot at all.

I could however boot into single user (with lots of errors)
but was not really sure what to do next.  I tried fsck but there
was a warning that I could severely corrupt the / partition,
so I declined to follow through with it.

Next, I shutdown the system, rebooted with the original drive
with the clone added as secondary drive, and brought up GParted
and took a look at the cloned drive's partition and everything appears
fine except the / partition, it appears with a black border, has a warning
exclaimation icon, and the partition is marked as "Unknown".

Can someone give me some guidance as to post-followup to dd, or
perhaps a repair of / partition, or to simply download Gparted-Live
and make a partition to partition copy of / (which I am downloading
as I write up this post)?

Curiously, why is it that dd works for XP/Vista and not Fedora-9?


More information about the fedora-list mailing list