File recovery on ext3 using LVM

Jonathan Berry berryja at
Sat Jul 26 22:36:43 UTC 2008

Hi all,

Okay, I know this is a long shot, but I might as well ask and see if
there is anything else to try.  I recently lost some pictures because
when importing into F-Spot, I accidentally selected not to copy the
pictures to the hard drive.  Now the F-Spot database references the
files on the flash card, which has been erased and the files
overwritten (I tried recovering from the flash card, no luck).  I've
noticed that when doing an import in F-Spot, it copies the files over
to the hard disk during the import.  If you hit cancel or change the
copy option, it deletes the files.  So, for a short time, the files
*were* on my hard disk (or, at least in the buffer cache).  Of course,
I've been using my system for a couple days now (including a couple of
reboots), so the data may be gone.  But I don't want to give up unless
there is just no hope.

I am using LVM at the base and then ext3 as my filesystem on Fedora 9
x86_64.  Does anyone know of anyway where the data from these pictures
might still be around somewhere on the disk?  I tried debugfs using a
System Rescue CD live CD (I'm not sure where my Fedora DVD is). and
saw the directory the files were in using ls -d.  However the inode
listed now belongs to another file, so it looks like there is no easy
way to get to the directory information to possibly find the files in
the directory.  Is there maybe something in LVM that might still have
blocks (extents?) from the files hanging around?

Any ideas?


More information about the fedora-list mailing list