livcecd-iso-to-disk: USB key do not boot (BIOS setup is fine)

Bruno Costacurta pubmb.bco at
Thu Jul 31 10:13:49 UTC 2008


I'm trying to build a USB bootable key with file 'Fedora-9-i686-Live-KDE.iso'

Command is :
sudo livecd-iso-to disk Fedora-9-i686-Live-KDE.iso /dev/sdd1

which runs fine, boot loader included, and reports that USB key is 
ready for use ... however the key is not ignored during boot (the sequence 
continue correctly with following drive in the BIOS boot order).

I'm using an Asus eee pc (model 900) which is correctly configured to boot via 
USB key as I tried it with a Debian bootable USB key which boots fine.
I also tried another .iso, (precisely the EEdora dedicated to Asus eee) but 
got same problem.

fdisk -l /dev/sdd

Disk /dev/sdd: 1030 MB, 1030750208 bytes
32 heads, 62 sectors/track, 1014 cylinders
Units = cylinders of 1984 * 512 = 1015808 bytes
Disk identifier: 0xb0bcd68e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *           1        1014     1005857    6  FAT16

which looks correct.
So opparently the problem come from livecd command whatever final report OK.
Is there some knwon problem with livecd-iso-to-disk ? I'm using Fedora-9.
Or can I build a USB key using another as a workaround  ?

Many thanks for attention and any clue.


More information about the fedora-list mailing list