'Splain please re: mixer, alsa, pulseaudio and tvtime??

William Case billlinux at rogers.com
Sun Jul 26 02:18:54 UTC 2009

Hi Mikkel;

Still no sound.

On Sat, 2009-07-25 at 13:30 -0500, Mikkel L. Ellertson wrote: 
> William Case wrote:
> > Hi Mikkel;
> > 
> > There is probably no need to reply to this post -- unless you see
> > something obviously wrong.  I am just posting to get the results on the
> > record -- so to speak.
> > 
> OK - I have F11 in a virtual machine now, so I can play with the
> differences while still having my normal setup running. To get a
> list of the control names to use, you have to tell amixer to use
> card 0, instead of the default. The default gives you the pulse
> audio controls. Try:
> amixer -c 0 controls
> or
> amixer -c 0 scontrols
> and see if that works better.

To get a clean start by first getting tvtime working with ALSA alone, I
removed PulseAudio, rebooted and ran:

]$ amixer controls and amixer -c 0 controls

]$ amixer scontrols and amixer -c 0 scontrols (just for to see)  On both
(to be expected) I got:

Simple mixer control 'Master',0 -yes  numid=38
Simple mixer control 'Headphone',0 -err
Simple mixer control 'PCM',0 -err mute not implemented
Simple mixer control 'Front',0 -yes numid=19
Simple mixer control 'Front Mic',0 -err
Simple mixer control 'Front Mic Boost',0 -err
Simple mixer control 'Surround',0 -yes numid=3
Simple mixer control 'Center',0 -yes numid=5
Simple mixer control 'LFE',0 -yes numid=6
Simple mixer control 'Side',0 -yes numid=9
Simple mixer control 'Line',0 -yes numid=14  -- the best/ but no sound
Simple mixer control 'CD',0 -yes numid=12
Simple mixer control 'Mic',0 -err
Simple mixer control 'Mic Boost',0 -err
Simple mixer control 'IEC958',0 -err
Simple mixer control 'IEC958 Default PCM',0 -err
Simple mixer control 'PC Speaker',0 -yes numid=22
Simple mixer control 'Capture',0 -err
Simple mixer control 'Capture',1 -err
Simple mixer control 'Channel Mode',0 -err
Simple mixer control 'Input Source',0 -err
Simple mixer control 'Input Source',1 -err

I then tried each simple mixer control with tvtime.  

]$ tvtime --mixer=hw0:'Control Name' returned
mixer: attach error: No such file or directory
mixer: Can't open mixer hw0:Line, mixer volume and mute unavailable.
mixer: Can't open device hw0, mixer volume and mute unavailable."

I then opened Advance Volume Control; set everyone of the controls
listed by amixer scontrols to unmute 100% (see list above) and tried
that.  Next I tried each control individually or in combination
according to its numid.

]$ tvtime --mixer=default/'Control Name' opened tvtime and made the
volume keyes (+/-) functional.  This is the opposite of what happened
with PulseAudio installed.  On the list above, I have marked each
'Control Name' with a -yes if no error was returned and -err if there
was an error.  See example below.

$ tvtime --mixer=default/Speaker
Running tvtime 1.0.2.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/bill/.tvtime/tvtime.xml
mixer: find error: Success
mixer: Can't open mixer default, mixer volume and mute unavailable.
mixer: Can't open device default/Speaker, mixer volume and mute
Thank you for using tvtime."

In every case, there was no sound.

Regards Bill
Fedora 11, Gnome 2.26.3
Evo.2.26.3, Emacs 22.3.1

More information about the fedora-list mailing list