'Splain please re: mixer, alsa, pulseaudio and tvtime??

William Case billlinux at rogers.com
Sun Jul 26 08:42:57 UTC 2009

Hi Michael;

On Sun, 2009-07-26 at 08:08 +0200, Michael Schwendt wrote:
> On Sat, 25 Jul 2009 22:18:54 -0400, William wrote:
> > To get a clean start by first getting tvtime working with ALSA alone, I
> > removed PulseAudio, rebooted and ran:
> 1) No need to reboot. You could have killed the pulseaudio daemon.

I know -- or at least I used to know.  I was no longer sure of anything,
and since we are looking for something that might be "wonky", better
safe than sorry.

> 2) Since tvtime doesn't do any audio playback, it doesn't have much
> (if anything) to do with PulseAudio. Since tvtime only accesses a mixer,
> disabling PulseAudio ensures that you can control the ALSA mixer
> channels without the sound server adding another layer (such as
> offering its own master volume channel).
> > ]$ amixer controls and amixer -c 0 controls

> No need to keep specifying -c 0 anywhere as long as there is only
> a single hardware device numbered by ALSA on your machine.
I know.  But based on the principle stated above.  The reason I wanted
to know were to look in the virtual file system was because of possible
"wonkiness" i.e something was mis-reporting the absence of -c 1 i.e.

> > Simple mixer control 'Line',0 -yes numid=14  -- the best/ but no sound
> I wonder what kind of Line input this is? You keep on pointing out
> that you haven't placed a cable between tv card and onboard audio,
> but even with onboard audio 'Line' and 'Mic' are external input
> jacks, aren't they?

That is the $64,000 question.  (You might be too young to remember the
$64,000 question.)

That was what started me on this whole "what do controls do?" quest and
trying to figure out various possible control combinations.  Using
'Line' or Line-in on my setup didn't seem logical.  It still doesn't.

I have external receptacles on my motherboard at the back of my computer
box -- one light green for incoming sound, and one light red (pink) for
a microphone.  Double checked visually and in my motherboard manual.  

*However* my tv tuner card has no sound output receptacle, did not come
with a line to use as an external connection line and shows no external
hookups in its manual.  Besides, I have looked several times and there
is no no receptacle for line-out.  I have tried experimenting with
earphones.  The receptacle on the tuner card that does exist is for
sound-in for a satellite dish.

On my old computer, the tv tuner did have an external line-out to a
sound card line-in.  So I am familiar with what I am looking for.  I do
not have an external line plugged into on this computer's sound.

> > Simple mixer control 'Mic',0 -err
> Interesting. Here, tvtime has no trouble using either of
>   tvtime --mixer=default/Mic
>   tvtime --mixer=hw:0/Mic
>   tvtime --mixer=hw:0/'Mic'

I must have made a typo on this one because tvtime --mixer=hw:0/Mic,
and, tvtime --mixer=hw:0/'Mic' works now.
> Not that it makes any sense, since no mic is plugged in, but still tvtime
> here succeeds in doing mute/unmute and changing the volume level.
> > Simple mixer control 'PC Speaker',0 -yes numid=22
> > Simple mixer control 'Capture',0 -err
> > Simple mixer control 'Capture',1 -err
> This is one of the special things about your audio chipset. Two
> Capture lines, likely one analog and one digital.

Yes.  Knowing that Canada and the U.S. were going to all-digital at
least two years apart (or more), I purposefully purchased a TV tuner
card that could be both analog and digital.  I checked on-line before
making the purchase (I forget where, but on one of the normal Linux
device recommendation sites).  My card was listed as working on Linux.

> > Simple mixer control 'Channel Mode',0 -err
> > Simple mixer control 'Input Source',0 -err
> > Simple mixer control 'Input Source',1 -err
> Two input channel chosers, two. Your earlier alsa info output
> showed that first one is Line and on, second one Mic and off.
> > mixer: Can't open mixer hw0:Line, mixer volume and mute unavailable.
> > mixer: Can't open device hw0, mixer volume and mute unavailable."
> Syntax error. "hw0:" is invalid.

Yea that was probably the typo.  Re-checked everything making doubly
sure there was no spelling mistakes.  "hw:0/CONTROL" in fact works the
same as "default/CONTROL".
> > $ tvtime --mixer=default/Speaker
> Not available in your list of controls, 

I know, but it was listed in tvtime.xml.  I thought I would give it a

> but default/'PC Speaker' is.

Yes.  It returns the volume set in Advanced Volume Control: 62%.  I set
PC Speaker to a different volume level from the others to see if it
would show up.  It did.

> > In every case, there was no sound.
> Why do you still expect sound? Which component (hardware or software)
> do you expect to "send sound" to your onboard audio chipset? 

I don't know.  I was hoping someone could tell me.

Remember, the original bug #510105 was simply "Description of problem:
No sound for my tv tuner"

Someone said that bug #510105 bug was a duplicate of #498167 "I Can't
get TVTime to output audio."

You posted to bug #510105

"Apparently, even with "alsamixer -c0" reporter cannot turn on any
input channel to make tv card audio output work. That means that internal
routing from audio between tv card and sound hw doesn't work/isn't enabled.
tvtime can't do anything about it if no mixer channel controls the tv audio
output. It's more of another tv card driver problem (also see bug 497750 - same
reporter, but F10)."

I agreed with you.

I posted this thread on the Fedora user list in order to straighten out
my use of controls before returning to bugzilla. 

> And how?
> ANd what does your tv card driver does related to audio?

I have filed a bug about PulseAudio and my tv tuner card #510105 and
subsequnetly about ALSA + PulseAudio #511178.

> We're going in circles, and that's why this is better continued in email
> than in bugzilla.

Not really. I appreciate that your speciality might be tvtime, but that
is relevant here because it is the application I would like to get
working wherever the fault lies.  

We have eliminated PulseAudio as being the problem -- at least in the
first instance -- by removing it and still having the same problem.

As hard as it has been to get there, my stupid choice of controls as a
cause has been eliminated.  Something is wrong with the controls, but it
is probably because something is broken, not because I didn't know what
I was doing.  I had to solve the controls because all the advice (often
contadictory) I had been getting from others was mainly about Control

ALSA or one of the sound or tuner driver(s) is probably the culprit.  If
I can narrow that down, perhaps I can file a useful bug against the
right component.

Regards Bill
Fedora 11, Gnome 2.26.3
Evo.2.26.3, Emacs 22.3.1

More information about the fedora-list mailing list