Drive Eaten!!!

Bill Davidsen davidsen at
Wed Jul 29 18:57:25 UTC 2009

Morgan Read wrote:
> Hello List
> This seems very very BAD!  If someone could help me through, it would
> be very much appreciated (understatement).
> I'm running f10 under gnome with a recent (couple of days ago) yum update.
> I was followed the instructions for setting the media defaults under
> new nautilus media tab here:
> I then went to the "Removable Drives and Media" under System >
> Preferences > Hardware to conform my old settings there with what I'd
> just done (above).
> The window opened but didn't complete it's draw - instead the display
> froze and there was frantic harddrive activity for some time - I went
> away and brushed my teeth...  Came back to find everything settled -
> except there was no longer any wireless connection.  I attempted to
> connect to my local network, but the connection couldn't be made -
> dropped back out as soon as the connection began to be established.
> OK, reboot...  There were an number of "failed" as the system went
> down... ... ...
> On reboot I had filesystem errors that fsck refused to pass.  Instead
> it invited me to run fsck manually and dropped me down to a boot
> prompt.  I ran fsck -AC and this is what I got (abridged):
> Inode 385125 has EXTENTS_FL flag set on filesystem without extents support.
> Clear <y>? yes
> Inode 385126 has extra size (22943) which is invalid
> Fix<y>? yes
> Inode 385136 has imagic flag set.
>          Clear<y>? yes
> Inode 385123 has compression flag set on filesystem without
> compression support. Clear<y>? yes
> Inode 385123 has INDEX_FL flag set but is not a directory
> Clear HTree index<y>? yes
> Inode 385123, i_size is 3426050370232693628, should be 0. Fix<?> yes
> Inode 385123, i_block is 21512961606650, should be 0. Fix<?> yes
> ... ... ...
> Other similar dialogue followed for 385122, 385136, 385127 and 385126
> ... ... ...
> Then for 467729 to 745, and back to 467738, 467740, 467741, 467743
> ... ... ...
> Then for 472689 to 472704
> ... ... ...
> Then for 472732 to 472736, and on to 472769 to 472784
> Checks for that first file system completed and moved on to the next
> file system.  Similar progress to the above was made, except absolute
> file names were given in brackets for the inode numbers, so:
> Inode 472696 (/usr/lib/ is an illegal
> character device.
> Clear<?> yes
> ... ... ...
> And, so it went on...
The bad news is that by running in recover mode you have deleted any clues or 
recovery information which would have aided in attempts to recover your data. 
The "good news" is that you probably didn't lose much, it sounds as if that f/s 
was pretty hosed anyway. I highly suspect hardware or power issues, but that is 
only a suspicion, don't take it as more.

> When finished I rebooted...  And, low - my system gets down to about
> starting nmbd before various start-ups fail for missing files.  Once
> through the start-up gnome attempts to start, but fails with
> continuous restarts.  I can't open a terminal on tty2, 3, 4, etc.
> And, I can only shutdown by pressing the power switch - which triggers
> an ordered shutdown.
> I ran a back up of the /home and /etc a few days ago - but, I've done
> work since...  I don't back up the rest of the system.
> Can anyone help me get my system back up please.  It's 12.15 midnight
> here, so I won't be back for a few hours.
I would be hesitant to try to recover that system if it were mine, I think 
hardware checks are in order, followed by a reinstall.

Hopefully someone else has an idea about recovery.

Bill Davidsen <davidsen at>
   "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot

More information about the fedora-list mailing list