[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem in today's update



In today's updates I hit two problems. The first was the package 'xcb-util' had some dependency problems with vlc,

vlc-core-1.0.0-0.11rc3.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libxcb-keysyms.so.0()(64bit) is needed by package vlc-core-1.0.0-0.11rc3.fc11.x86_64 (installed)

This was easily overcome (for now) by --skip-broken however the second problem is a bit puzzling, a library from gstreamer-plugins-base in today's update conflicts with a library of the same name from gstreamer-plugins-bad.

Transaction Check Error:
  file /usr/lib64/gstreamer-0.10/libgstselector.so from install of gstreamer-plugins-base-0.10.23-3.fc11.x86_64 conflicts with file from package gstreamer-plugins-bad-0.10.12-2.fc11.x86_64

A simple repoquery shows me this,

$repoquery -f /usr/lib64/gstreamer-0.10/libgstselector.so
gstreamer-plugins-bad-0:0.10.12-1.fc11.1.x86_64
gstreamer-plugins-base-0:0.10.23-3.fc11.x86_64
gstreamer-plugins-bad-0:0.10.11-4.fc11.x86_64
gstreamer-plugins-bad-0:0.10.12-2.fc11.x86_64

What is a "bad" library doing in base?

--
Suvayu

Open source is the future. It sets us free.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]