[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

yum update dependency problem today [libxcb-keysyms]



yum update is giving following errors

Has anyone seen anything similar ?

I believe that it is telling me
xcb-util.x86_64 0:0.3.4-1.fc11

will replace existing version but that the new version is missing libxcb-keysyms.so.0

[root naxos ~]# rpm -qa|grep -i xcb-util
xcb-util-0.3.3-2.fc11.x86_64

[root naxos ~]# rpm -ql xcb-util
...
/usr/lib64/libxcb-keysyms.so.0
/usr/lib64/libxcb-keysyms.so.0.0.0
...


John

--> Processing Dependency: libxcb-keysyms.so.0()(64bit) for package: vlc-core-1.0.0-0.11rc3.fc11.x86_64   
---> Package xcb-util.x86_64 0:0.3.4-1.fc11 set to be updated
---> Package xorg-x11-drv-nouveau.x86_64 1:0.0.12-40.20090528git0c17b87.fc11 set to be updated
--> Running transaction check
---> Package GeoIP.x86_64 0:1.4.6-1.fc11 set to be updated
---> Package polkit-qt.x86_64 0:0.9.2-1.fc11 set to be updated
--> Processing Dependency: libxcb-keysyms.so.0()(64bit) for package: vlc-core-1.0.0-0.11rc3.fc11.x86_64
--> Finished Dependency Resolution
vlc-core-1.0.0-0.11rc3.fc11.x86_64 from installed has depsolving problems
  --> Missing Dependency: libxcb-keysyms.so.0()(64bit) is needed by package vlc-core-1.0.0-0.11rc3.fc11.x86_64 (installed)
Error: Missing Dependency: libxcb-keysyms.so.0()(64bit) is needed by package vlc-core-1.0.0-0.11rc3.fc11.x86_64 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]