[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: bizarre rpm conflicts



Neal Becker wrote:
> This is really strange.  I have my own emacs-23.0.95 package.  I've built 
> and installed fine on my x86_64 F11 machines.  I just rebuilt on my i386 F10 
> box.  But when I try to install there, I get massive conflicts, like:
> 
>        file /usr/bin/emacs-23.0.95-nox from install of emacs-
> nox-1:23.0.95-1.fc10.i386 conflicts with file from package emacs-
> nox-1:23.0.95-1.fc10.i386
> 
> How can the file conflict with itself???
> Are there 2 of them?
> 
>  rpm -qlp RPM/RPMS/i386/emacs-nox-23.0.95-1.fc10.i386.rpm | grep /usr/bin/
> /usr/bin/emacs-23.0.95-nox
> 
> No, there's just 1.
> 
> WTF???
> 
> 
The conflict is between the package you are trying to install, and
the package that is installed. Try using the --replacepkgs option of
rpm, so that it will install the new package over the old one. If
that does not work, try doing an upgrade instead of an install and
use the --oldpackage option.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]