[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Preupgrade still not working



On Thu, 02 Jul 2009 12:53:13 +0100
Timothy Murphy <gayleard eircom net> wrote:

> stan wrote:
> 
> > Either this is a bug somewhere in the chain between you and fedora
> > or you have some kind of filtering activaed.  What happens if you
> > try wget or curl to get the file?  Or galeon or seamonkey or
> > konqueror?
> 
> Thanks for your reply.
> 
> wget seems to have the same problem:
> -------------------------------------
> [tim mary ~]$ wget http://mirrors.fedoraproject.org/releases.txt
> --2009-07-02 11:43:31--  http://mirrors.fedoraproject.org/releases.txt
> Resolving mirrors.fedoraproject.org... 209.132.176.122
> Connecting to mirrors.fedoraproject.org|209.132.176.122|:80...
> connected. HTTP request sent, awaiting response... 404 Not Found
> 2009-07-02 11:43:31 ERROR 404: Not Found.
> -------------------------------------
> 
> Konqueror has the same problem.
> 

Not a firefox issue.

> As you say, there is obviously something seriously amiss with my
> setup. I've tried wget on 3 different computers (2 laptops and a
> desktop), running Fedora-11, Fedora-10 and CentOS-5.3,
> and I get the same response.
> 
> But this is really weird (to me):
> I do get the file under Windows XP, with both Internet Explorer and
> Firefox, on the same laptop.
> 
> So it is just a failure under Fedora/CentOS.
> In all cases (Linux and Windows) the connection to the internet goes
> through the same CentOS-5.3 machine.

The fact that it works from the windows box shows that the address is
visible from your location.  That wget got a 404 says that the request
the server received was not for the same file that the windows box
sent.  It implies that the linux boxes are mangling the address somehow.

> 
> You mentioned "filtering".
> That certainly sounds like a plausible explanation.
> But where could I be filtering these connections?

I would guess at the CentOS server.  You could take the fedora laptop
to a local access point and try to get the file from there.  If it
succeeds, that says it is the CentOS server.  If not, there is
something wrong in the protocol on all the linux boxes you're sending.

> 
> I've actually had this problem for some time,
> so I have had to use the baseurl in fedora.repo and
> fedora-updates.repo rather than the mirrorlist.
> On the other hand, I just installed Fedora-11 on one laptop yesterday
> (from the KDE Live CD) and have made no modifications,
> though my home directory remains the same.
> 
> As always, any enlightenment gratefully received.

I've given pretty much all the help I can.  At this point you need
to set up some packet monitoring on the CentOS server and try both the
wget from fedora and the browser request from windows.  Compare the
packets.  There must be a difference.  I don't know the details of how
to do that, though I'm pretty sure it isn't that difficult and is
available in linux.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]