[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Firefox and other apps slow with name resolution



On a freshly installed F11 machine I noticed that Firefox was taking a
long time to do name resolution. Using Wireshark, I saw the resolver
querying DNS twice even though it appeared to get an answer the first
time. It was waiting 5 seconds before issuing the second query, which
was the source of my delay in Firefox. I found a few old fedora-list
threads (some from years ago) mentioning that IPv6 was causing this
problem, so I disabled IPv6 name resolution in Firefox by setting
network.dns.disableIPv6 to true in about:config. It solved my problem,
but of course only for Firefox and not other programs. To fix it for
everything I reverted the change in Firefox and disabled IPv6 by
creating a file /etc/modprobe.d/disable_ipv6.conf (because I didn't
know if it was a good idea to edit the other /etc/modprobe.d/*.conf
files) containing this line

    install ipv6 /bin/true

and rebooted. It worked. I'm happy about that, but I'm confused.
Despite my supposed disabling of ipv6, ipv6.ko still shows up in
modprobe -l. What exactly did the line above do in that case?

Tim



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]