[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: emu10k1 sound driver in F10/F11



---- "Kevin J. Cummings" <cummings kjchome homeip net> wrote: 
> Steve wrote:
> > I want to upgrade my home F9 system to F10 but I seem to recall someone on this list saying that the emu10k1 driver for my Audigy card is no longer supported and I need this (or I need to buy a new sound card!). A few other people were upset about this and there was some talk of someone picking up the maintenance of this driver.
> > 
> > Does anyone know the current situation?
> 
> I recently tried to install F11 (via the live DVD) on a Dell Dimension 
> 3000.  Couldn't install F11 directly (anaconda got lost trying to 
> partition the available space), so I reverted back to F10, installed it, 
> then used preupgrade to update to F11.  While it worked, there was no 
> sound.  Since the Dell has a:
> 
> > 02:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
> 
> I assumed the same as you.  There is an open bug about kernel errors 
> with this driver:
> 
>  > https://bugzilla.redhat.com/show_bug.cgi?id=502698
> 
> There were a bunch of kernel oopses using the F11 live DVD.  All got 
> sent automagically to kernel.org.
> 
> What I later discovered was that (for whatever reason), the installation 
> chose the wrong output device for my sound card (it was using a digital 
> output instead of the analog output).  Selecting the proper output made 
> sound work for me.  And no more kernel oopses, either.

Well, I decided to try the upgrade from F9 to F10 and see what happenned.
I used preupgrade and it was probably the smoothest upgrade I've ever done. Almost everything appeared to work with no tweaking. (I had to change the device of my Windows partition from sdb1 to sda1 and remount it)

Now, however, I have found a really annoying problem with sound playback. The playback of mp3s 'skips' at irregular intervals with an average of about every once every 15s. I've tried vlc, rhythmbox and exhaile and they all have the same problem. I tried using aplay with a .wav file and that had the same problem too. aplay reported an underrun whenever the problem happened. I had none of these problms with F9.

ALSA bug?

kernel-2.6.27.25-170.2.72.fc10.i686

alsa-lib-devel-1.0.20-1.fc10.i386
alsa-plugins-pulseaudio-1.0.18-2.fc10.i386
alsa-utils-1.0.20-2.fc10.i386
alsa-plugins-jack-1.0.18-2.fc10.i386
alsa-lib-1.0.20-1.fc10.i386
bluez-alsa-4.30-2.fc10.i386

Steve




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]