[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: preupgrade 10 -> 11 pain: network error



On 07/05/2009 10:50 PM, stan wrote:
On Sun, 05 Jul 2009 21:24:51 -0400
brian<brian zijn-digital com>  wrote:

But I'm wondering *when* I can edit that. If I run preupgrade again,
how do I edit that file before rebooting if it's preupgrade that
generates the file? Presumably, the file is written to after the user
clicks "reboot".

Try passing the anaconda option asknetwork (or the static one you
found) to preupgrade on the command line when you start it.  Maybe it
gets passed on to anaconda.


Reporting back from a shiny new F11!

I added the following to /boot/upgrade/ks.cfg:

network --bootproto=static --ip=192.168.1.2 \
--netmask=255.255.255.0 --gateway=192.168.1.1 \
--nameserver=4.2.2.1 --device=eth0

(this was all on one line, without the backslashes)

I ran preupgrade again and, when presented with the reboot button,
reopened /boot/upgrade/ks.cfg It had, indeed, been completely
overwritten (I knew it was generated by preupgrade but thought it might
save that line). However, the good news was that it had written and
closed the file before offering the reboot. I was concerned it might do
all that when the user initiates the reboot. So, I added that line and
went ahead with the reboot.

Long story short: anaconda connected fine and the upgrade was successful.

I'll start a new thread regarding the /boot partition issue.

Thanks for your help.

UPDATE: sending this from my Mac--Thunderbird is unusable :-(


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]