[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with evolution after migrating to FC11




Date: Sun, 05 Jul 2009 20:41:39 -0430
From: "Patrick O'Callaghan" <pocallaghan gmail com>
Subject: Re: Problem with evolution after migrating to FC11
To: fedora-list redhat com
Message-ID: <1246842699 18046 5 camel bree homelinux com>
Content-Type: text/plain

On Sun, 2009-07-05 at 09:44 -0500, Aaron Konstam wrote:
> On Sun, 2009-07-05 at 22:46 +0530, Shridhar Sahukar wrote:
> > Hi,
> >
> > I was using evolution on FC10, and after I migrated to FC11, I am
> > seeing a problem as described below:
> >
> > I have created a bunch of sub folders under Inbox, which are organized
> > in some hierarchy, and I have defined filters to transfer each of the
> > mail into selected folder. On FC10, whenever a new mail appeared into
> > a sub folder, the folder would get highlighed indicating number of new
> > mails. However, this is not happening on FC11.
> >
> > On FC11, when ever a new mail appears into Inbox (not filtered into
> > subfolder), then Inbox folder gets highlighted, but same doesnt happen
> > with sub folders.
> >
> > I suspected it to be an issue with evolution version (2.26.2), I tried
> > using an older version (2.24.5), but still facing same problem. So
> > wondering if it is anything to do with FC11.
> >
> > Highly appreciate any  help in this regard.
> >
> > Regards,
> > Shridhar
> Just a suggestion. I create the folders for receiving filtered mail
> under On This Computer not under Inbox. Inbox is left for mail that is
> not filtered by a rule. That works as you want it to where filtered mail
> appears in the appropriate box.
>
> I am not sure why you want them to be a hierarchy under Inbox. Could you
> explain?

Some IMAP servers hang the folder structure below Inbox, rather than
parallel to it. This is a server configuration decision and isn't under
the user's control.

Of course the OP hasn't said if he's using an IMAP server or local mail,
so I've no idea if this is pertinent here. In any case, it shouldn't *in
itself* cause the reported behaviour.

One thing to verify: Evo only checks for new mail in folders other than
Inbox if you specifically configure it to do so. The easiest way is to
right-click on the folder, select Properties, and check the box marked
"Always check for new mail in this folder".

poc

Aaron/poc,

Thanks for the inputs.

1. As per Aaron's suggestion, I moved all the folders under "On This Computer", but still the results are same.

2. I am creating hierarchy as below:
    On This Computer (or Inbox earlier) ----
                                                               |----- Company----
                                                                                          |--- engineering
                                                                                          |--- management
                                                               |----- Friends-------
                                                                                          |--- x
                                                                                          |--- y

With above hierarchy I find it easier to organize all the mails and locate them quickly. So I have setup filtering rules for most of the senders/subjects so that they go straight into the corresponding directory.

3. wrt suggestion from poc, I dont find any option like "Always check for new mails in this folder" for any folder. Under folder properties dialogue I see only one option - "Index message body data" which is checked by default. Not sure what this option means, and if it has any relevance to my problem.

4. As I had mentioned earlier, I havent changed any setting after moving from FC10 to FC11. I have been using evolution since FC8 and the way I use has been same. So the problem is very specific to either FC11 or new version of evolution on FC11.

Let me recapture the problem again:
Whenever evolution downloads a new mail, it is filtering it properly into the destination sub folder. But the folder name doesnt get highlighted with new mail notification. However, if I go and click on the corresponding folder, immediately the folder name gets highlighted with number of unread mails. So the highlighting of folder with number of unread mails is not happening automatically. Due to this, I wont know if any new mail as arrived unless I go and click on each of the folders.

Regards,
Shridhar


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]