[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VirtualBox problems



Patrick O'Callaghan wrote:
> On Tue, 2009-07-07 at 14:11 -0300, Paulo Cavalcanti wrote:
>> Try adding
>>
>> none /sys/bus/usb/drivers      usbfs      devgid=509,devmode=664  0 0
>>
>> to /etc/fstab, where devgid is a group allowed to access the usb
>> devices
>> (e.g., usbusers), which vboxusers is part of.
> 
> I have a 'usb' group and a 'vboxusers' group. I set the above fstab line
> using the vboxusers GID, but it didn't make any difference. Then I tried
> the usb GID and that didn't work either.
> 
> I ran "VBoxManage list usbhost" with the Bluetooth dongle connected and
> got the following:
> 
> UUID:               b431984b-e53d-462a-85b2-d037c3fd361a
> VendorId:           0x0a5c (0A5C)
> ProductId:          0x2111 (2111)
> Revision:           1.0 (0100)
> Manufacturer:       Broadcom Corp
> Product:            ANYCOM Bluetooth USB-250 UHE
> Address:            /proc/bus/usb/003/032
> Current State:      Unavailable
> 
> This is exactly the same whether or not VBox is running or the VM is
> actually running.
> 
> poc
> 
What does "ls -l /proc/bus/usb/003/032" give you for permissions? I
also suspect that the line in /etc/fstab is not going to affect
anything until a new initrd is built, and may not help then. The USB
file system is mounted in the initrd. (This is why is does not show
up when running mount, but does show up when running "cat
/proc/mounts".)

You could try something like:

mount -o remount,devgid=515,devmode=664 none /proc/bus/usb usbfs

I have not tried it, as I use a udev rule to set the permissions on
a specific device instead ofall USB devices.

MLE
-- 
I am not a number,
I am an individual with a unique number.

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]