[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Samba Issues [ALMOST SOLVED] still need help



On Tue, 2009-07-07 at 16:40 -0400, Christopher K. Johnson wrote:
> Mike Adolf wrote:
> > Could the problem be
> > due to the ntfs file system on the shared folder? If I change it to ext
> > how does windows use it?
> >
> > Mike
> How does which windows use it?  If the ntfs partition is solely mounted 
> by your Linux OS, and shared with Windows on other boxes via Samba, then 
> the shared filesystem should be ext3 or ext4 (F11) and then selinux can 
> label the files correctly and it should work.  The other Windows boxes 
> will see it only through Samba and do not need to know whether it is or 
> is not ntfs.
> 
> If you intend to dual boot the system with the ntfs partition and boot 
> into windows on that hardware sometimes, then you need to keep the 
> filesystem as ntfs.
> 
> In the latter case you will not be able to set selinux labelling on the 
> subdirectories and files in that filesystem, only for the mount point.


Christopher

I do want to dual boot and use the disk on windows. However, when I
tried the same chcon command with the folder path replaced by the mount
point /media/Backup, I got the same errors.

Thanks for your reply,
Mike



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]