[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dell Perc 4/DC and PowerVault 220S - firmware upgrade under Fedora



Mikkel,


Mikkel L. Ellertson wrote:
Howard Wilkinson wrote:
  
I have 4 Powervault 220s devices which need the firmware on the embedded
controller cards upgraded. I have download the dell Linux utilities and
tried to do the upgrade. However, this is failing - seemingly because I
have mirrored drives for the root filing systems (software mirror using
md) which get broken by the scan that the upgrade utility attempts. I
have tried to get round this by building a ramdisk with the required
utilities on it but the firmware upgrade still fails.

The systems are currently Fedora 9 based. Has anybody managed to do this
sort of upgrade using these utilities and if so HOW?

Regards, Howard.

    
Could you boot in the rescue mode, not mount the drives, and have
the utilities on a USB drive? Or better yet, build a bootable stick
with a live CD and the utilities?

Mikkel
  
I had thought of this and am trying to construct a suitable initrd image to try this out - the machine has no local mountable devices other than its hard discs. The root discs are on the internal controller and the PV units are on an additional Perc 4/DC controller. The Dell utility is (I think) taking the root discs out when scanning the scsi environment.

Given the hardware I will have to do a network boot (PXE) and try to run rescue from there, which means getting the Dell utilities into the rescue image.

I was hoping that somebody on the list had done some very similar and could tell me that this is going to work, I have the horrible feeling that I am going to end up with this failing to work because the Fedora environment is not enough like the Redhat Enterprise 3 environment the tools were developed for.

I will keep you apprised of any progress (or lack of)

Howard.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]