[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with uw-imap-static (Fedora 9) on x86_64 can anybody help?



Rex,

Rex Dieter wrote:
Rex Dieter wrote:

  
Howard Wilkinson wrote:

    
I am building a version of Asterisk for use on Fedora 9 derived systems.
The environment is patched up to the latest updates. The Asterisk
Voicemail does not work unless linked against the static library for
c-client. This worked fine on the i386 platform but is failing with the
following message on the x86_64 platform.

/usr/bin/ld: /usr/lib64/c-client.a(osdep.o): relocation R_X86_64_32
against `a local symbol' can not be used when making a shared object;
recompile with -fPIC


Can anybody point me to what I need to change (presumably in the uw-imap
build) to get this to work?
      
It needs (re)building with -fPIC compiler flag.  I can help fix that, but
F-9 has reached EOL, and no further updates are allowed.
    

In the meantime, try this build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1460664

-- Rex

  
I have rebuilt using the packages from koij and get the self same error message. Any thoughts?

Howard.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]