[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 11 UTF-8 and fonts (clearcase and citrix ICAClient, and maybe motif in general?)



On Mon, Jun 15, 2009 at 10:55 AM, Andy Wang<dopey74 gmail com> wrote:
> Hi all,
> I posted this on fedoraforum.org when I was testing the preview F11
> and just did again to see if anyone using F11 release has any ideas,
> but I thought I'd try the mailing list as well:
>
> *** post from fedora forum ***
> The Citrix ICAClient and clearcase gui tools don't launch properly. I
> get the following:
> Warning:
> Name: FONTLIST_DEFAULT_TAG_STRING
> Class: XmRendition
> Conversion failed. Cannot load font.
>
> on the console in a nice steady stream. Citrix's wfica just fails to
> launch, and the wfcmgr is missing all fonts. Clearcase gui tools
> complains that it's unable to create a text drawing font set and the
> tools exit.
>
> I can workaround the problem two ways, one LANG=C instead of
> en_US.UTF-8 or removing the cjk fonts, specifically, the following two
> packages:
> cjkuni-uming-fonts-0.2.20080216.1-23.fc11.noarch
> cjkuni-fonts-common-0.2.20080216.1-23.fc11.noarch
>
> Any ideas on other solutions for this problem?
> *** end post from fedora forum ***
>
> Does anyone have any thoughts about this, the clearcase gui tools and
> ICAClient are the only two motif applications I have readily available
> to test (wish those would just move off motif, but I'm doubting that
> IBM will do anythign with clearcase anytime remotely soon).
>
> Just looking for general ideas on how to troubleshoot this.  I don't
> understand font loading anymore, especially with the UTF-8 encoding
> stuff, so I don't know why LANG=C would actually allow this to work.
> Can anyone provide a short primer on how that works, or let me know
> what's a good tool to try to debug font loading and find out what
> fonts it either can't load, or can't find?
>
> Thanks,
> Andy

Thanks for figuring this out! I was about to go crazy. One question
though, how the heck did you figure out it was those two packages
causing the problems?

Richard


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]