[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: XFCE wonkiness after upgrading from Fedora10 -> 11



On Wed, Jul 8, 2009 at 10:23 PM, Kevin Fenzi<kevin scrye com> wrote:
> On Wed, 8 Jul 2009 14:42:48 -0700
> Lonni J Friedman <netllama gmail com> wrote:
>
>> Greetings,
>> I've just upgaded from Fedora10 to 11, and I'm running across a bunch
>> of XFCE problems.  Apologies if these are Fedora specific or known
>> already:
>> 0) New windows appear _under_ pre-existing windows.  At first I
>> thought I was going crazy because apps would never seemingly run,
>> until I realized that they were happily sitting behind other apps.
>
> There is a thread on the upstream devel list about this...
> It's unclear to me at least what causes the issue. ;(

Ugh.  Does that imply that there's no solution either?

>
> What do you have for:
>
> Automatically give focus to newly started applications.

unchecked

looks like if i check this off, then the badness goes away, but that
definitely wasn't needed back in Fedora 10

> and
> Automatically raise windows when they receive focus.

uncheched

>
> In your window manager prefs? Does changing these affect the behavior?
> Also, do you see it only with Terminal and Thunar? Or is it everything?

everything exhibits this problem

>
>> 1) The menu editor(xfce4-menueditor) seems to be gone entirely.  Its
>> not in the settings-manager, and there's no xfce4-menueditor binary
>> anywhere.  I did a yum search for it as well, and found nothing.  That
>> wouldn't be a big deal except that....
>
> Yep. The menu handling was totally redone in 4.6, and the editor was
> not ready to ship. They decided that this functionality was not worth
> blocking the entire release on, so it's not available. ;(
> It should be back better and stronger in 4.8.
>
>> 2) My /home/netllama/.config/xfce4/desktop/menu.xml is completely
>> ignored, and I'm getting a default menu with all sorts of entries that
>> I don't want or need, and none of the entries that I do need.
>>
>> thanks in advance for any guidance or feedback.
>
> Take a look at:
>
> http://wiki.xfce.org/howto/customize-menu
>
> for info on customizing menus in 4.6.
>
> Hope that helps some.

thanks, i'll give that a try.  what I'm still puzzled by is why my
pre-existing menu.xml is being ignored.



-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
L. Friedman                                    netllama gmail com
LlamaLand                       https://netllama.linux-sxs.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]