[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Broke my system trying to upgrade to rawhide using yum



Hi,

Today I finally gathered up the courage to "live on the edge" and
upgrade to rawhide. So I disabled all the other repositories and
enabled rawhide. (Fedora and rpmfusion, living rpmfusion enabled was
probably a bad idea) Then I ran

$ yum update --skip-broken (as I was having trouble with vlc)

While installing I noticed yum encountered some errors. Most of then said,

"bash: xmalloc: cannot allocate <some numbers> bytes allocated 0 byte"

After yum was done it said it failed to update several packages. When
I tried to reboot my desktop froze after logging me out halfway. I had
to do a hardboot but that got stuck too after some error messages from
init. Then I tried booting to runlevel 3 with no luck. Finally I could
boot using the DVD choosing to rescue. But after the disk gets mounted
at /mnt/sysimage when I do chroot /mnt/sysimage, I get the same error
as yum was showing while installing,

"bash: xmalloc: cannot allocate <some numbers> bytes allocated 0 byte"

I have a separate /home so my data is most likely safe, but how do I
make this bootable again? What did I do wrong that things went so bad?
I would still like to upgrade to rawhide,  any help with this will be
a lifesaver.

Thanks in advance.

-- 
Suvayu

Open source is the future. It sets us free.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]