[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Eee PC Boot Problem



Steve Berg wrote:
I've solved this problem, but thought I'd report it anyway.

I twice installed F11 on my Eee 1000 and both times I was unable to boot
afterwards. All I'd get was the grub command line. The issue seems to be
that the presence of the USB key is confusing the grub installer, and
it's setting up grub with the wrong (hdX) stuff. I was able to fix this
by re-installing grub, but obviously that is not for the meek.

I saw the same thing on my 901, during the install process there's one
screen where you can select which drive to boot from.  It seems to think
it should be booting from /dev/sdc which was my USB stick.  Changing that
option to /dev/sda and everything worked fine without having to futz
around with grub.

I did that, too, but then noticed that the list of bios mappings read as follows:
   /dev/sdc      (hd0)
   /dev/sda      (hd1)
   /dev/sdb      (hd2)
I figured that must be wrong, but didn't do anything at the time. That, ultimately, is what caused the boot failure.

A normal user wouldn't even know about bios mappings, let alone what to do there.

rh



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]