[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F11 (Thpd T30) : reproducible display loss



	To my great satisfaction, it became possible shortly before the 
release of F11 to run two of my four legacy suites of proprietary GPS/
topo map software under wine.The two suites I prefer (Garmin's own and 
one of Maptech's) now install, launch, and run -- and most of them 
usually do the crucial function, transferring data to and from my GPSs.

	(Details in a June 29th post here, titled "Mappery : uncertain 
success with Fedora/Wine/Garmin")

	There is a snag, though.

	Disclaimer : what I know of hardware would go in a gnat's eye, 
comfortably.

	I have a T30 Thinkpad, into which a hardware-savvy young friend 
recently put a new hard drive -- one I had bought from a friend, who 
thought it to have 70 GB; df -h tells me it has 228 GB.

	The machine is running Fedora 11, on which I have installed 
Garmin's TOPOUS2008 under Wine. This combination on three of my four PCs 
not only launches and runs, but also transfers data to and from my Garmin 
GPSs. It launches and runs on a T42, too -- and used to talk to the GPS, 
but doesn't now.

	At first, when I launched the map software on the T30, either by 
mouse or from the CLI, it churned a moment, then the monitor went black, 
and failed to respond discernibly to anything except holding down the 
power button. 

	I've been told I may need to update the BIOS, but I get lost 
trying to follow the directions for doing that at 

http://www-307.ibm.com/pc/support/site.wss/MIGR-45745.html

(the BIOS update page).

         Yesterday evening, I tried launching the map software again
(which is always very slow to launch). I *think* I did it on the
T30, but from the CLI instead of the mouse, by c&p from the launcher
to the CLI; the up arrow gets me the command: env WINEPREFIX="/home/
btth/.wine" wine "C:\Garmin\MapSource.exe"

         The screen soon went black. One of the several LEDs near the
power button stayed lit. I thought, wrongly I now believe, that it
simply indicated the presence of wall power. (It looks like a circle
containing either a Z or an N, rotated 45 degrees.)

         I waited a while, then hit the power button and waited
again. Nothing visible happened. I held the power button down, for
what seemed a very long time. Finally the LED turned off.

         I hit the power button again; nothing happened; I waited a
while, and hit it yet again. This time the T30 booted up. I left it
at the F11 login screen.

         This morning, without logging into the T30, I did ssh -X
into it from my #1 PC, the one I'm on now. Then I gave the env
WINEPREFIX="/home/btth/.wine" wine "C:\Garmin\MapSource.exe" command
again -- expecting the T30 to crash, but possibly send me
interesting messages as it did.

         It didn't crash. It opened the same map display as on this
machine (which I had opened by c&p with the same command.) It gave
these messages :

[btth Hbsk2 ~]$ ssh -X 192.168.1.109
btth 192 168 1 109's password:
Last login: Sun Jul  5 16:23:53 2009 from 192.168.1.102
[btth Thpd30 ~]$ env WINEPREFIX="/home/btth/.wine" wine
"C:\Garmin\MapSource.exe"
fixme:bitblt:X11DRV_ClientSideDIBCopy potential optimization: pixel
format conversion
err:imagelist:IMAGELIST_InternalExpandBitmaps creating new image
bitmap (x=23904 y=24)!
fixme:bitblt:X11DRV_ClientSideDIBCopy potential optimization: pixel
format conversion

         (Meanwhile, by comparison, PC #1 was showing these messages :

[btth Hbsk2 ~]$ env WINEPREFIX="/home/btth/.wine" wine
"C:\Garmin\MapSource.exe"
fixme:bitblt:X11DRV_ClientSideDIBCopy potential optimization: pixel
format conversion
fixme:bitblt:X11DRV_ClientSideDIBCopy potential optimization: pixel
format conversion)

         I turned on a GPS, which was still connected to the serial
port on the T30, and started trying to transfer data in to the T30.
It didn't see the GPS. I edited preferences, trying com1 through
com8 (!) and the "auto" setting (before and after the com ports); no
joy, and in fact no response, except what I'd've gotten without any
GPS.

         But the T30 still didn't crash, and the map display is
still open and working usably on one of my PC#1 workspaces -- just
like the one native to PC #1. I have that open also, on the same
workspace. The only difference I find between them is that the
native one says merely "Untitled - MapSource" across the top, while
the other adds a parenthesis "(on Thpd30.localdomain)"

         I took this to mean that it's not the map software itself
that's the problem, but its demands on X. Does that make sense?

         After a while, I closed the display from the T30, but not
the ssh -X link -- nor the plain ssh link I also had open to it.
Then I logged into the T30 from its keyboard, and launched the map
program again. 

	Today, after a reboot, the T30 now does launch and run the topo 
software, on its own display. That fails to see either of my GPSs, and to 
find them if I tell it to. It does zoom, pan, and do most of its usual 
things. 

	If I try to launch its Celestial Information (showing phase, rise 
and set of the moon), the display on the T30 goes black; but I can still 
get to it with ssh and also with ssh -X.

	If I try to change the size of the map symbols, the T30's display 
goes black -- except for the left panel. That also still shows the 
cursor, but mouse clicks on launchers do nothing visible.

	In this condition, it still lets me in with both plain ssh and 
ssh -X. ssh -X can launch the map display -- defectively: it opens a 
window on my #1 PC, but leaves a wide swath on the right and another 
underneath without the map display. (The swaths show strips of whatever 
workspace I click to the map one from.)

	I also get error messages in the ssh'ing terminal on my #1 PC 
that differ from the earlier ones :

[btth Thpd30 ~]$ env WINEPREFIX="/home/btth/.wine" wine "C:\Garmin
\MapSource.exe"
X11 connection rejected because of wrong authentication.
X11 connection rejected because of wrong authentication.
Application tried to create a window, but no driver could be loaded.
Make sure that your X server is running and that $DISPLAY is set 
correctly.
err:ole:apartment_createwindowifneeded CreateWindow failed with error 0
^C
[btth Thpd30 ~]$ 
[btth Thpd30 ~]$ baobab &
[1] 4162
[btth Thpd30 ~]$ X11 connection rejected because of wrong authentication.

	Inside the display, the usual mouse actions work -- except for 
those that don't on the T30 itself, either. Even if I go into the T30 
display on PC #1, and click Utilities > Celestial Information, that 
works, too (in the useful section of the window with the swaths).

	So I'm altogether at sea about what is wrong with the T30 -- the 
new hard drive, the old BIOS, its version of X, or what.

-- 
Beartooth Staffwright, Neo-Redneck Not Quite Clueless Power User
I have precious (very precious!) little idea where up is.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]