[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: exim: SELinux



John,
I tried as you suggested below.  The result...no errors!!!

Ok so now I'm confused.  exim is normally started at boot time by
/etc/init.d/exim.  There is no reference to boot in that script.  That
script is part of the exim package.

Here's what I did:
   - as root, I ran '/etc/init.d/exim stop'
   - as root, I ran 'exim -bd -d"+all" >/tmp/ex.file 2>&1'

   - as a normal user, I ran 'fetchmail'
     In the past, this would result in an AVC error; but not this time.
     BTW, there was one new message in my mail file as a result of this.

Frank

On Tue, Jul 14, 2009 at 12:33 AM, John Horne<john horne plymouth ac uk> wrote:
> On Mon, 2009-07-13 at 13:05 -0700, Frank Chiulli wrote:
>> Nigel,
>> No reference to boot in the exim.conf.  That was one of the first
>> things that I checked.
>>
> Could there be a redirection (e.g. via /etc/aliases) or a .forward file
> referring to /boot somewhere on your system? It would require having an
> account within /boot which in itself would be a bit odd.
>
> Alternatively, try running exim with debugging cranked up in a terminal
> session, e.g:
>
>    exim -bd -d"+all" >/tmp/ex.file 2>&1
>
> Then try accessing mail from your isp using a separate session. Once
> done (or it has failed), control-c the above session and look in the
> 'ex.file' to see where /boot is being used.
>
>
>
> John.
>
> --
> ---------------------------------------------------------------
> John Horne, University of Plymouth, UK  Tel: +44 (0)1752 587287
> E-mail: John Horne plymouth ac uk       Fax: +44 (0)1752 587001
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
> Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]