[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: missing audio after F11 install on IBM T61 Thinkpad



Hi,

Thanks very much for your detailed e-mail! Here are my findings:

--- On Thu, 7/16/09, stan <gryt2 q com> wrote:

> From: stan <gryt2 q com>
> Subject: Re: missing audio after F11 install on IBM T61 Thinkpad
> To: fedora-list redhat com
> Date: Thursday, July 16, 2009, 6:39 PM
> On Thu, 16 Jul 2009 14:37:47 -0700
> (PDT)
> Globe Trotter <itsme_410 yahoo com>
> wrote:
> 
> > 
> > Hi,
> > 
> > I have been missing audio after installing F11 (from
> the XFCE spin)
> > on my IBM Thinkpad T61. I looked around and even tried
> the following:
> > 
> > http://forums.fedoraforum.org/showthread.php?t=206868&highlight=problems+sound
> > 
> > but this did nothing. alsamixer -c0 brought in a while
> lot of stuff
> > and I dutifully changed everything from <MM> to
> 00 without
> > understanding the implications, but to no avail. Any
> suggestions? I
> > sort of miss the old system-config-sound and then
> clicking to see
> > whether sound would work on the older Fedoras (before
> 10). 
> > 
> > This machine had previously been upgraded from
> F8->F9->F10 so I never
> > felt the problems in F10. I chose to install this time
> because of the
> > ext4 filesystem, etc and hence getting sound working
> is a different
> > ball-game.
> > 
> > Thanks in advance for all the help!
> > Best wishes,
> > T
> > 
> > 
> >       
> > 
> I'll try some suggestions, but I suspect you are running
> HDA-intel
> architecture as most new sound cards have that
> architecture, and I'm
> not very familiar with it.  I use AC97 sound cards and
> they work fine.
> USB sound cards that adhere to the standard are supposed to
> work fine
> too, but I haven't experience with them either.  Also,
> while I have
> pulseaudio installed, I have it disabled as the default
> device and
> don't start it on boot.  So I can't help a lot with
> pulse stuff.  There
> is a website, http://www.pulseaudio.org  where you
> can probably get
> help.  Others here might help you with pulse.
> 
> The first suggestion is to go to the link below and run the
> shell
> script.  It will print a whole bunch of information,
> much of it useful
> only for developers, but very comprehensive picture of your
> sound
> system.  If you post it here, it allows people to see
> your sound setup,
> and perhaps spot a problem.

I have run the shell script and here is the output:

http://www.alsa-project.org/db/?f=514e34407ba9bad84fe86effa0942e0565747136

I am delighted with help!


> 
> You probably don't have any of the configuration from F10,
> but it would
> be great if you had run the alsa-info.sh program and saved
> the output
> so you could run it again and look at the
> differences.  Good idea for
> next time.
> 
> http://www.alsa-project.org/alsa-info.sh
> 
> Run a wav file with aplay and see if it plays sound.
> 
> aplay -D plughw:0,0 some.wav
 
Yes, it does. So it appears that sound does work and the system is not born mute:-)


> This will tell you if alsa has identified your device
> properly.
> 
> Use something like audacity or amarok, which allows you to
> select the
> device to use, import an audio file, and see if it plays.
Did you mean audacity or audacious? I tried the latter.

No, it does not. Tried audacious with all sorts of settings, once again without understanding what I am doing, to no avail. Tried both .wav and .mp3 files.

> Does the vu
> meter show sound while playing, even if it is silent? 

I presume this is the stuff that goes dancing around on the audacity screen? Yes, it does "show" sound while playing.

> Try different
> outputs.  What if you do the same thing after a
> pulseaudio --kill  ?

No change.

> Have you run alsamixer to get the pulse volume control and
> turned it up?

I tried changing everything up to 71% but to no avail. 


I haven't tried this last bit here yet. Thanks very much again! 

> Go to the link below and download the latest driver
> snapshot.  You can
> install it as it is supposed to be backward compatible, but
> that isn't
> necessary at this point.  If you just unpack it, go
> into the directory
> that it unpacks to, something like alsa-driver-snapshot,
> and then into
> alsa-kernel/Documentation you will find all the driver
> documentation.
> Grep for your codec.  Look at the HDA files for
> troubleshooting
> information.
> 
> ftp://ftp.kernel.org/pub/linux/kernel/people/tiwai/snapshot/alsa-driver-snapshot.tar.gz
> 
> I've had no major issues with sound in F11 x86_64, but I
> don't have
> hda-intel cards.  I have pulseaudio installed, but
> don't use it.
> Before I disabled it, it seemed to work fine.

Best,
T



      



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]