[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

mount.nfs4: Protocol not supported



I already been posted this in response to someone else, but it may not be obvious to users of this problem.

nfs-utils-lib-1.1.4-6.fc11.i586
nfs-utils-1.2.0-3.fc11.i586

Basically the latest nfs update disables NFS4, the server log file shows something like:

Jul 18 10:47:10 username kernel: svc: 192.168.10.100, port=897: unknown version (4 for prog 100003, nfsd)

On the client, the message will be something like:

mount.nfs4: Protocol not supported


rpcinfo -p (on the server) will not show any version 4 protocols.

The short term fix is:

edit your "/etc/init.d/nfs" file as follows:

Comment out line 97 and add the following line (which removes the -N 4.1)

        echo -n $"Starting NFS daemon: "
        # For now, turn off the nfs41 support
#       daemon rpc.nfsd -N 4.1 $RPCNFSDARGS $RPCNFSDCOUNT
        daemon rpc.nfsd $RPCNFSDARGS $RPCNFSDCOUNT

Then, restart your NFS server (service nfs restart)

It should then work (mine does)

Albert.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]