[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Recent update of F8 server to F10



Hi,
I just recently updated my email server from F8 to F10. Now, while I'm still receiving emails, 2 of my milters aren't running:

	spf-milter    and     clamav-milter

I discovered that I was running a really jury-rigged old copy of an fc4 spf-milter, and I had to update quite a few perl packages to get this updated to fc10 packages. I found the city-fan.org repo and started using this as this is where my old fc4 RPM came from. After much updating of some perl packages to fc10 versions, I am left with this error when starting the milter:

# /sbin/service spf-milter start
Starting spf-milter: spf-milter: Failed to set timeout value!
                                                           [FAILED]

??

Failed to set timeout value????  Am I missing something basic here?

My sendmail.mc file has the following lines:

dnl #
dnl # Sendmail SPF Milter support
dnl #
define(`confMILTER_LOG_LEVEL',`9')dnl
INPUT_MAIL_FILTER(`spf-milter', `S=local:/var/run/spf-milter/spf-milter.sock, F=, T=C:4m;S:4m;R:8m;E:10m')dnl

I can see the timeout values there. But, this may not be the timeout being complained about. in sendmail-milter-spf-1.42.pl I found the following code:

    # Now we set a fairly large timeout. The idea here is to set it so large, that
    # the Milter will not try and compete with the sendmail T= timings, which allow
    # for a more fine-grained tuning.

    if (not Sendmail::Milter::settimeout ('8192')) {
        log_error_and_exit ("Failed to set timeout value!");
    }

Did I miss something basic? Can someone please tell me what I've one wrong? This used to work with F8.

Thanks!

--
Kevin J. Cummings
kjchome rcn com
cummings kjchome homeip net
cummings kjc386 framingham ma us
Registered Linux User #1232 (http://counter.li.org)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]