[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Samsung Laser printers and F10/11?





Mike Cloaked wrote:
> 
> 
> I am going to test the printer and scanner functions via a usb connection
> on an F10 machine in the coming days.  Having downloaded
> sane-backends-1.0.20-4.fc10 and its associated library from
> updates-testing, I will try the scanner in the next few days, and will
> also try to install the printer using the ppd file and see if it will work
> without the Samsung provided other stuff. I will be pleased if both
> functions can be made to work. The xerox_mfp.conf file has been amended to
> include the 4500w details, and a 19-libsane-scx4500w.fdi has been made, so
> hopefully this will allow the scanner to operate but it now needs testing.
> 
> Additionally it would be nice to test this to see if it will work via
> ethernet and wireless for printing, though I understand that scanning will
> only work via usb.
> 
> If it works I will also try to test on an F11 laptop as a test ahead of
> moving my main machine on F10 to F11 in the next couple of weeks.
> 
> 

I thought I would report my first tests on using the Samsung scx-4500W under
F10.

I did a fair bit of reading before deciding what to try and in the end did
the following:

I downloaded the driver set and untarred them. The drivers are available
from
http://www.samsung.com/uk/support/download/supportDown.do?group=printsolutions&type=printsolutions&subtype=monomultifunctionproducts&model_nm=SCX-4500W&language=&cate_type=all&dType=D&mType=DR&vType=&prd_ia_cd=06010300&disp_nm=SCX-4500W&model_cd=&menu=download

However I did not install their script(s).
Instead I pulled the following two files out of their Unified Driver file:
I added the file
rastertosamsungspl (from
cdroot/Linux/i386/at_root/usr/lib/cups/filter/rastertosamsungspl) to
/usr/lib/cups/filter/

and scx4500q.ppd (from cdroot/Linux/noarch/at_opt/share/ppd/) to
/usr/share/cups/model/samsung/
Note the permissions are 644

Also did cd to /usr/share/cups/model/foomatic-db-ppds and made directory
samsung, then
gzip -c
/home/mike/Documents/printer-info/4500w-drivers/cups-f10/scx4500w.ppd >
samsung/scx4500w.ppd.gz

That was all that seemed to be needed. Anyway I plugged in the usb line to
the main machine here running F10, and turned on the printer whilst tailing
the messages file.

On startup it immediately recognised the printer and the messages file
showed that the device had been found correctly and culminated in:
Jul 20 20:37:32 home1 kernel: usbcore: registered new interface driver usblp
Jul 20 20:38:00 home1 hal_lpadmin: Added printer SCX-4500W-Series

A window popped up saying the printer had been added and offered me to check
the settings - all that I changed was the paper size from the US Letter to
our A4 size and then I ran a test page - which looked perfect.

Then I printed a system status page from the printer itself which was fine,
and then did a test print from the main machine - all seems well.

cups started eating lots of cpu so I restarted it and it settled down
nicely. I then checked that the printer was visible to other machines on the
LAN and it worked nicely. 

I have not used the ethernet cable yet, nor changed the wireless settings.
I'll have to put it on the local network and give it a sensible ip address
rather than the default 192. address that it comes with.

I have also been preparing the setup to allow scanning but not had a chance
to test that yet.

Anyway it is very pleasing that the printer is working, despite being an
unsupported printer - and only using the two files pulled from the other
Samsung linux application allowed the printer to work nicely.


-- 
View this message in context: http://www.nabble.com/Samsung-Laser-printers-and-F10-11--tp24389848p24577326.html
Sent from the Fedora List mailing list archive at Nabble.com.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]