[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 11: can't read debugging symbols anymore



On 07/19/2009 12:54 AM, Mildred Ki'Lya wrote:
> On 07/17/2009 12:29 AM, Tom Horsley wrote:
>   
>> I just tried building my Qt app "kewpie" with debug info and running
>> it under debugger, and it works fine for me. (Fedora 11 64 bit).
>>
>> Are you trying to look at locals inside a constructor? g++ is
>> notoriously dreadful at generating debug info for constructor
>> bodies for some reason.
>>
>> http://home.att.net/~Tom.Horsley/kewpie/kewpie.html
>>   
>>     
> Thanks
>
> Or perhaps that's because I miss the time to update to Fedora 11 from
> rawhide, and I had quite some problems back then when I downgraded from
> rawhide to F11. I may still have repositories that gives me wrong
> updates or rawhide packages.
>   
That was it. I thought I found all the rawhide packages on my computer,
but I had gcc 4.4.0-8 from rawhide still there (I found it while trying
to install eclipse, complaining that gcc 4.4.0-4 wasn't available)

I think that's solved now. (still have to check)

Thanks

Mildred


-- 
Mildred Ki'Lya
╭───────── mildred593@online.fr ──────────
│ Jabber, GoogleTalk: <mildred jabber fr>
│ Website: <http://ki.lya.online.fr>           GPG ID: 9A7D 2E2B
│ Fingerprint: 197C A7E6 645B 4299 6D37 684B 6F9D A8D6 9A7D 2E2B


Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]