F11: kill -9 doesn't work

Terry Barnaby terry1 at beam.ltd.uk
Wed Jul 22 14:01:50 UTC 2009

On 07/22/2009 02:07 PM, Paul W. Frields wrote:
> On Wed, Jul 22, 2009 at 01:02:09PM +0100, Terry Barnaby wrote:
>> Hi,
>> I have noticed on several occasions, that running "kill -9<pid>" on
>> a GUI 3D process that is locked at 100% CPU usage (X-Server 100% also)
>> does not work. The 100% lockup I'm sure is due to the currently buggy
>> 3D support (ATI in my case), but I am surprised that I cannot kill
>> either the GUI or X processes. Only a reboot appears to work.
>> Has something changed here ??
> If you provide more details, such as the actual process you're
> running, people might be able to try to duplicate the problem.  I've
> never seen an occasion where kill -9 didn't work, but that doesn't
> mean it's not possible with some horribly written code.
The system in question is a dual Xeon system running Fedora-11 with all updates
to 2009-07-22. Graphics board is an ATI RV280 [Radeon 9200 PRO].
I have some applications installed from rpmfusion including paraview.

Currently if I run paraview, X goes to 100% and I can no longer
operate the system via mouse/keyboard. Via a network login I
can "killall -9 X" but that does nothing to X. I have also
tried killing paraview in the same way with no effect (possibly
after trying to kill X).

I know 3D is horribly broken in F11 :( as well as many other things,
but I would have thought that kill -9 should still work ...



More information about the fedora-list mailing list