yum objects to over 100 i586 dependencies ?

Kevin J. Cummings cummings at kjchome.homeip.net
Thu Jul 23 18:24:39 UTC 2009

On 07/23/2009 01:17 PM, William Case wrote:
> On Thu, 2009-07-23 at 12:08 -0400, Todd Zullinger wrote:
>> William Case wrote:
>>> I tried to yum update the latest releases for my
>>> system.
>>> The dependency check listed over 100 i586 files to be installed (a
>>> few for updating).  Of course yum and I both objected.
>> Yep, there was a problem with epiphiany in the latest updates push
>> that caused this.  It's being fixed in a currently running updates
>> push (but a push has been taking a day or so to complete recently).
>>      https://fedorahosted.org/rel-eng/ticket/2008
> I had to exclude  epiphany-extensions, firefox,	xulrunner, and, yelp to
> get my updates.
> I guess yelp now uses xulrunner ??

I had a slightly different set of dependencies.  The one update hanging 
me up was xine-lib.i586.  If I updated, it tried to drag in 34 packages 
(all i586 versions).  If I tried to delete it, it wanted to remove 9 
packages, including:  kdepim.x86_64, kdepim-libs.x86_64, and
kdepimlibs-akonadi.x86_64.  So, I chose the latter.  *Then* if I try and 
re-install kdepim.x86_64, it tries to drag all of those i586 RPMs back 
in (plus the 9 I just removed)!  *WHY?*  I decided I could do without 

Kevin J. Cummings
kjchome at rcn.com
cummings at kjchome.homeip.net
cummings at kjc386.framingham.ma.us
Registered Linux User #1232 (http://counter.li.org)

More information about the fedora-list mailing list