[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RAID 1 error question - boot problem.



Robin Laing wrote:
Hello,

I am trying to help someone get a system to reboot after a system issue. He is not the builder of the system and the person that knows the system is away for a few weeks. Great timing. :)

It is Fedora 10.

Two drives, two partitions each drive which one is a mirror.

/dev/sda is partitioned as /boot and / which is mirror 1.
/dev/sdb is partitioned as swap and /

The system wouldn't restart on the reboot and came up with an error after creating the raid arrays and then saying that it cannot find /dev/md0. I don't have the exact error message right now.

Using an Ubuntu disk (persons personal preference) the system was booted into a live system and using gparted the partitions were shown to be as above with as I see it, one error.

/dev/sda1 ext3 boot
/dev/sda2 ext3 /   raid

/dev/sdb1 Swap
/dev/sdb2 Unknown  / raid

Running mdadm /dev/sdb2 --examine shows that the partition superblock is showing RAID 1 and that it is clean.

As this is a critical system, it is a priority and is being used as a virtual server.

With only the second drive installed, we tried to run fsck.ext3 on the /dev/sda2 (normally b2) with no success. We also tried /dev/md0 as Ubuntu has created the /dev/md0 from the single drive.

The user has not tried to boot with only the one drive in yet. He is making a copy of the drive on a different system.

Now, the question. On booting from a mirror 1 array, if there is a problem with the raid system, how does the boot process read the mdadm.conf file when it is on the RAID array that needs to be created? Is there some data that is stored in the /boot or someplace else that has the necessary info to tell the system how to build the array?

Is it part of the /boot/grub/device.map or /boot/System.map* ?

Any suggestions to where to start?

The linux-raid group would have been a better choice, but this is a simple question. The mdadm.conf file should get put in the initrd file, which is in the /boot partition, which you didn't mirror for some reason. I'm guessing that sda2 is a better place to start, since that's recognizable as an ext3 partition. Having a partition identify as "Unknown" is usually not a good thing. I would mount that partition and copy the contents to a secure backup if this is critical.

"I don't have the exact error message right now" doesn't help, I suggest backing up sda2, and sda1 if you can, noting the error message, and post back. Without more information I am guessing that the sdb2 partition is in some way hosed, do NOT run fsck on sda2 before backing up, and run with the "-n" option to see what condition the f/s is in. I doubt you've lost your data yet, don't do anything which would change that.

--
Bill Davidsen <davidsen tmr com>
  "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]