[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11 Sound without PulseAudio ?





On 07/24/2009 03:32 PM, Chris wrote:
2009/7/24 Bill Davidsen <davidsen tmr com>:
  
Anyone who reads this list will know I despise PA totally, but vlc has
worked fine for me  using PA, in FC11, in FC11 running in a VM under FC9 KVM
(from cli) and in FC9.
    

Hi Bill. There was a discussion on this list a couple of hours ago in
which someone rightly pointed out that PA gets a lot of undeserved
flak for issues which aren't actually its fault - not to say that it
doesn't have issues of course! It's often the case that disabling or
uninstalling PA causes sound to start working which naturally makes
one think that PA was at fault, but there are other layers involved in
the confusing world of Linux audio.

Anyway, other than defending PA which is clearly not perfect as yet,
I'd like to try to be helpful! You say that VLC works whilst other
applications do not. Am I right to assume that PA is running whilst
VLC is working? If that's the case then PA is unlikely to be the cause
of your audio problems. Certainly for me, if PA is running, no sound
works at all but I know this is because of a misconfiguration with my
audio card that I don't know how to fix.

It sounds to me like your problem is in the application layer. What
applications are you having problems with? What desktop are you
running? Apologies if I'm repeating advice you've already had but I
haven't seen any of your threads before and I'm just a user who's had
a lot of audio problems over the years, not an expert! Here's a bunch
of rpms you might try installing to provide full sound support:

phonon-backend-gstreamer
phonon-backend-xine
(I've had issues with the xine backend so if you've got it installed,
you could try removing it)
phonon
phonon-devel
gstreamer-plugins-good
gstreamer-plugins-ugly
gstreamer-plugins-flumpegdemux
gstreamer-tools
gstreamer-python
gstreamer-plugins-bad
gstreamer-plugins-bad-extras
gstreamer
gstreamer-ffmpeg
gstreamer-plugins-base
ffmpeg

HTH, Chris.

  

While I accept the fact the PA  does indeed "work", my problem with it is
that the PA daemon was consuming upt 35% of my CPU!
I do not care how "well" PA worked as far as producing sound.
I DO care when it eats 35% of my CPU!!
I happily killed the PA daemon and have never been sorry I did so.
I do not understand why it is enabled by default.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]