[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: exim: SELinux



Sorry for the delay in responding.  I've been on the road and unable
to access my Fedora box.  So after a little grief with SELinux and
permissions I have a log file of exim.  I'd post it here but it's 724
lines long.  I looked for boot in the file but came up empty.  Is
there some snippet of the file that I could post?

Frank

On Thu, Jul 16, 2009 at 1:37 AM, Gordon Messmer<yinyang eburg com> wrote:
> On 07/14/2009 07:33 PM, Frank Chiulli wrote:
>>
>> Here's what I did:
>>    - as root, I ran '/etc/init.d/exim stop'
>>    - as root, I ran 'exim -bd -d"+all">/tmp/ex.file 2>&1'
>>
>>    - as a normal user, I ran 'fetchmail'
>>      In the past, this would result in an AVC error; but not this time.
>>      BTW, there was one new message in my mail file as a result of this.
>
> Sadly, starting exim in that way will not give it the same SELinux context
> as it would get when run by the init process.  If you stop the service and
> "service exim start", it should get its old context, and the AVC messages
> should return.  That'll get you back to where you can debug the problem.
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
> Guidelines: http://fedoraproject.org/wiki/Communicate/MailingListGuidelines
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]